Finger face with a question
はい、ごめんください。

先日、WordBench 新潟 に参加した際、カスタムフィールドの使いドコロを知りました。

カスタムフィールドの便利さは何となく知っていたのですが、DB 直接構えばいいや~とか思ってたので、ずっと使わないでいました。

それを実例とともに紹介されて感動し、お客さんにも優しい UI が提供できると知って、今まさに作ろうとしている機能をこれで対応しようとしたわけです。

Advanced Custom Fields はあったものの…

プラグイン → 新規追加 で「Advanced Custom Fields」を探し、インストール。そして有効化。
口笛吹きながらさらっと入れることができたんですが・・・左のメニューに表示されない、だと・・・?

バージョンか?競合か?と調べても、特に問題なし。
グーグル先生に尋ねたところ、昨日フォーラムに上がってました。

WordPress › フォーラム » advanced custom fieldsをインストール→メニューに表示されない

そこでも返信したのですが、作者のサイトに確認しに行ったら、ちゃんと書いてありました。

All Discussions – Plugin Support

Dear ACF users, WordPress have recently changed their terms and conditions for hosted plugins. Over the next few weeks I will be focusing on rebuilding and improving ACF to ensure it adheres to the new rules.

In this time, I would appreciate your patience and ask you to first search for information before posting a new discussion.
Cheers, Elliot

俺訳するとこんな感じ。

ACF(advanced custom fields)ユーザーの皆様、WordPress では最近、プラグインのホスティング契約条件が変更されました。
今後数週間にわたって、新しいルールに準拠できるようACFを再構築し改善することに注力いたします。
ご迷惑をおかけしますが、新しくコメントする前にご承知おきください。

主な原因は「プラグインホスティングの契約条件が変わった」ということらしいのですが、ソースがよくわかりませんでした。公式に乗っていても問題を孕んでいるプラグインもあるというし、それらを一掃するために何か変わるのかなとゲスパー。

そんな訳で、公式から自動インストールはしばらくできないようです。
そのため、Github から ZIP ファイルをダウンロードして、解凍したものをアップロードする必要があります。

2013.2.11 時点では、下記のどちらかをダウンロードすれば良いでしょう。

* 3.5.8.1 (latest) – https://github.com/elliotcondon/acf/ (安定版)
* 4.0.0 (beta) – https://github.com/elliotcondon/acf4 (ベータ版)

画面中の「ZIP」をダウンロードして、「ZIP」からダウンロードしたものを advanced-custom-fields フォルダに入れることで動作します。安定版の方はちゃんと日本語化されていました。

有効化しても特に変化がわからないから、「まだ有効化されていません!有効化するには別途ファイルをダウンロードする必要があります」とかアナウンスがあればいいのにと思った次第。
自動インストールはこういう所でつまづいてしまいますね。自戒も込めてエントリー。


8件のコメント

  1. 今後同じようなプラグイン増えてくるのかなあ/ブログなう:http://t.co/MaHUslJG [WP] Advanced Custom Fields を自動インストールしたら使えない件→ダウンロードが必要 | @mekemoke

  2. “[WP] Advanced Custom Fields を自動インストールしたら使えない件→ダウンロードが必要 | @mekemoke” http://t.co/5JIq2gl9

  3. そうだったのか!! → [WP] Advanced Custom Fields を自動インストールしたら使えない件→ダウンロードが必要 http://t.co/nbpglLQk @mekemokeさんから

  4. これか / [WP] Advanced Custom Fields を自動インストールしたら使えない件→ダウンロードが必要 http://t.co/4YAP0yku

  5. あぶないあぶない / [WP] Advanced Custom Fields を自動インストールしたら使えない件→ダウンロードが必要 http://t.co/y3OA3yKx @mekemokeさんから

  6. “[WP] Advanced Custom Fields を自動インストールしたら使えない件→ダウンロードが必要 | @mekemoke” http://t.co/IRiJeC7K

  7. [WP] Advanced Custom Fields を自動インストールしたら使えない件→ダウンロードが必要 – http://t.co/2jK8bGYD08

  8. ぽけったー [WP] Advanced Custom Fields を自動インストールしたら使えない件→ダウンロードが必要 http://t.co/pixpY4k6p4